Thanks for the reply, Bipin. The field is not enabled for field security profile.